[Webkit-unassigned] [Bug 54034] New: ScriptExecutionContext shutdown is a bit of a mess

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 8 14:34:51 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=54034

           Summary: ScriptExecutionContext shutdown is a bit of a mess
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: Mac OS X 10.5
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: jorlow at chromium.org
                CC: eric at webkit.org, ap at webkit.org, fishd at chromium.org,
                    abarth at webkit.org, jorlow at chromium.org,
                    dgrogan at chromium.org


Message ports are closed in "stopActiveDOMObjects".  The function should probably be renamed or split in two.

The blob stuff is shut down in ~ScriptExecutionContext, but the object is ref counted, so when this happens is not deterministic.  It should probably be done with the message ports are closed, but...

void FrameLoader::frameDetached() does |m_frame->document()->stopActiveDOMObjects();| and then |detachFromParent();| which fires the unload handlers.  So, in theory, new active dom objects or message ports could be created there, right?


Perhaps there are other problems as well?  I'm not an expert on this stuff, but I'm happy to take a crack at cleaning it up.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list