[Webkit-unassigned] [Bug 52136] Add TestOutput classes to webkitpy.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Feb 6 15:38:21 PST 2011


Ojan Vafai <ojan at chromium.org> changed:

           What    |Removed                     |Added
  Attachment #81184|commit-queue?               |commit-queue-
               Flag|                            |

--- Comment #22 from Ojan Vafai <ojan at chromium.org>  2011-02-06 15:38:21 PST ---
(From update of attachment 81184)
View in context: https://bugs.webkit.org/attachment.cgi?id=81184&action=review

Just a couple more nits I noticed. Sorry. :)

> Tools/Scripts/webkitpy/common/net/testoutput.py:95
> +    def is_new_rebaseline_for(self, other):

is_new_baseline_for? a "rebaseline" is not really a thing. :)

> Tools/Scripts/webkitpy/common/net/testoutputset.py:79
> +            if name_match and (actual_match or (self._include_expected and expected_match)):

nit: typical webkit style for this would be to invert the if clause and add a continue. makes for less deeply nested indents and arguably more readable code.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list