[Webkit-unassigned] [Bug 53776] Device element patch 1: adding a basic skeleton of the HTMLDeviceElement and the Stream objects.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Feb 5 01:55:06 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=53776
Eric Seidel <eric at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #81242|review? |review-
Flag| |
--- Comment #4 from Eric Seidel <eric at webkit.org> 2011-02-05 01:55:05 PST ---
(From update of attachment 81242)
View in context: https://bugs.webkit.org/attachment.cgi?id=81242&action=review
build failures.
> Source/WebCore/dom/DeviceType.cpp:43
> +// Avoid using static Strings. Code should not run on WebKit load.
> +const char* DeviceType::s_names[] =
> +{
> + "invalid",
> + "media"
> +};
We've historically done this with AtomicStrings and an init() method. But in this case for only 2 types, I'm not sure having an array actually buys us anything besides complexity.
> Source/WebCore/dom/Stream.h:49
> + static PassRefPtr<Stream> create(HTMLDeviceElement*, const String& url);
Should these urls be strings or KURLs?
> Source/WebCore/html/HTMLDeviceElement.cpp:87
> + HTMLElement::defaultEventHandler(event);
> + return;
This could just be one line.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list