[Webkit-unassigned] [Bug 53529] [fileapi] Add support for filesystem: URI handling
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Feb 1 16:55:22 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=53529
--- Comment #11 from Adam Barth <abarth at webkit.org> 2011-02-01 16:55:22 PST ---
(From update of attachment 80849)
View in context: https://bugs.webkit.org/attachment.cgi?id=80849&action=review
>>> Source/WebCore/page/SecurityOrigin.cpp:69
>>> +static bool schemeRequiresRequestCapabilityForDisplay(const String& scheme)
>>
>> We probably don't want to use the term "Capability" here because Capability has a special meaning in security, and this doesn't quite match that meaning.
>
> I disliked this name too; do you have an alternate suggestion? SchemeRegistry::shouldTreatURLSchemeDisplayAsRequestRestricted? More words doesn't necessarily make it clearer to me.
Yeah, all these functions are poorly named. Maybe SchemeRegistry::canDisplayOnlyIfCanRequest ?
>>> Source/WebCore/page/SecurityOrigin.cpp:152
>>> return adoptRef(new SecurityOrigin(BlobURL::getOrigin(url), sandboxFlags));
>>
>> I see that you're copying the pattern here from BlobURL, but that's not a good pattern. We should fix Blob URL not to use this style either.
>
> Do you have a pattern in mind? Should the code that's currently in FileSystemURL::getOrigin() just move into the SecurityOrigin constructor?
Yeah, or just into a free function in an anonymous namespace in SecurityOrigin.cpp.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list