[Webkit-unassigned] [Bug 52221] Autocorrection should respect undo.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Feb 1 13:42:33 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=52221
--- Comment #10 from jpu at apple.com 2011-02-01 13:42:32 PST ---
Attachment 80814 is a preview of proposed patch, since the patch will depend on the landing of patch for bug 53255. However, I'd like to get some feedback on the proposed changes.
This patch consists of following components:
1. To identify edit command that is generated by autocorrection, I added a new member variable EditCommand::m_createdBySpellCorrection.
2. When undoing a command that is generated by autocorrection, we add Replacement and SpellCheckingExemption markers to undone range. This is achieved by calling Editor::unappliedSpellCorrection().
3. In order to avoid having undone range selected, I have created two new edit commands, SetSelectionCommand and ReplaceRangeCommand. SetSelectionCommand does nothing more than setting the selection. And ReplaceRangeCommand is a composition of SetSelectionCommand followed by ReplaceSelectionCommand.
4. Clean up the signatures of SelectionController::setSelection() and ReplaceSelectionCommand::ReplaceSelectionCommand(), since those bool arguments are become too difficult to follow. I have consolidated those bool arguments into enum bi masks.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list