[Webkit-unassigned] [Bug 74605] [GTK] Simplify loader client WebKit2 GTK+ API
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Dec 15 11:10:11 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=74605
Martin Robinson <mrobinson at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |mrobinson at webkit.org
--- Comment #5 from Martin Robinson <mrobinson at webkit.org> 2011-12-15 11:10:11 PST ---
(In reply to comment #4)
> (In reply to comment #3)
> > > Source/WebKit2/UIProcess/API/gtk/WebKitWebView.h:71
> > > +} WebKitLoadStatus;
> >
> > So I think this should be renamed to WebKitLoadEvent since WEBKIT_LOAD_REDIRECTED is not really a status, but something that happened to us.
>
> hmm, good point!
I guess we can go two ways here: try to make the enum represent a status or an events For instance if we used events, they enum values would be something like:
WEBKIT_LOAD_STARTED_PROVISIONAL
WEBKIT_LOAD_REDIRECTED
WEBKIT_LOAD_COMMITTED
WEBKIT_LOAD_FINISHED
and the argument names would be something like previous_load_event instead of previous_load_status.
If we think of them as states we would have:
WEBKIT_LOAD_PROVISIONAL
WEBKIT_LOAD_REDIRECTING
WEBKIT_LOAD_COMMITTED
WEBKIT_LOAD_FINISHED
Personally, I prefer the 'event' structure because that's the interface that the C API gives us and I think it more closely matches what's happening within WebCore.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list