[Webkit-unassigned] [Bug 73397] [BlackBerry] Upstream BlackBerry porting of pluginView

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 14 07:02:15 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=73397





--- Comment #13 from Antonio Gomes <tonikitoo at webkit.org>  2011-12-14 07:02:15 PST ---
(From update of attachment 119167)
View in context: https://bugs.webkit.org/attachment.cgi?id=119167&action=review

Looks good to me.

> Source/WebCore/plugins/blackberry/PluginViewBlackBerry.cpp:680
> +        // Clip against any frames that the widget is inside. Note that if the frames are also clipped
> +        // by a div, that will not be included in this calculation. That is an improvement that still
> +        // needs to be made.

It should be a FIXME

> Source/WebCore/plugins/blackberry/PluginViewBlackBerry.cpp:704
> +        while (current->parent() && visible) {
> +            // Determine if it is visible in this scrollview.
> +            visibleContentRect = current->parent()->visibleContentRect();
> +
> +            // Special case for the root ScrollView. Its size does not match the actual window size.
> +            if (current->parent() == root())
> +                visibleContentRect.setSize(windowSize);
> +
> +            contentRect.intersect(visibleContentRect);
> +            visible = !contentRect.isEmpty();
> +
> +            // Offset to visible coordinates in scrollview widget's coordinate system (except in the case of
> +            // the top scroll view).
> +            if (current->parent()->parent())
> +                contentRect.move(-visibleContentRect.x(), -visibleContentRect.y());
> +
> +            current = current->parent();
> +
> +            // Don't include the offset for the root window or we get the wrong coordinates.
> +            if (current->parent()) {
> +                // Move content rect into the parent scrollview's coordinates.
> +                IntRect curFrameRect = current->frameRect();
> +                contentRect.move(curFrameRect.x(), curFrameRect.y());

This whole block could be simplified, I think. see WebPagePrivate::getRecursiveVisibleWindowRect. Maybe in a follow up though

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list