[Webkit-unassigned] [Bug 74383] Upstream PlatformMouseEvent and LocalizedStrings into WebCore/platform/blackberry

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 13 18:30:51 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=74383





--- Comment #5 from Daniel Bates <dbates at webkit.org>  2011-12-13 18:30:51 PST ---
(From update of attachment 119125)
View in context: https://bugs.webkit.org/attachment.cgi?id=119125&action=review

> Source/WebCore/platform/blackberry/LocalizedStringsBlackBerry.cpp:24
> +

Nit: I suggest that we remove this empty line as I don't feel it improves the readability of this file.

> Source/WebCore/platform/blackberry/LocalizedStringsBlackBerry.cpp:68
> +String platformDefaultLanguage()

Would it make sense to re-write this function using WTF::String functions instead of using the std::string routines? That is, can we just convert BlackBerry::Platform::Client::get()->getLocale() to a WTF::String then manipulate it as as such? I suggest taking this approach since the WTF::String functions tend to be a bit more concise and at the end of the day we want to return a WTF::String.

> Source/WebCore/platform/blackberry/LocalizedStringsBlackBerry.cpp:71
> +    // getLocale() returns a POSIX lcoale which uses '_' to separate language and country

lcoale => locale.

country => country.

> Source/WebCore/platform/blackberry/LocalizedStringsBlackBerry.cpp:72
> +    // however, we use '-' instead of '_' in WebCore (e.g. en_us should read en-us)

however => However

Missing period at the end of this line.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list