[Webkit-unassigned] [Bug 74229] background-image transitions trigger between equivalent images

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 9 17:28:02 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=74229


Chris Marrin <cmarrin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |cmarrin at apple.com




--- Comment #6 from Chris Marrin <cmarrin at apple.com>  2011-12-09 17:28:02 PST ---
View in context: https://bugs.webkit.org/attachment.cgi?id=118668&action=review

> Source/WebCore/page/animation/AnimationBase.cpp:384
> +       // If either is null, return false. If both are null, return true.

This comment doesn't seem to be adding value. You're just stating in text what the code is actually doing. Either get rid of the comment or say why you're doing all these tests. It may be that the only comment needed is why a null style is never equal to a non-null. Isn't it possible that the non-null style would have the same effect as a null style?

> Source/WebCore/page/animation/AnimationBase.cpp:392
> +        return StyleImage::imagesEquivalent(imageA, imageB);

A better name would be good. What does "equivalent" mean? Are you doing a pixel by pixel test? Assuming you're actually just saying that they both point to the same underlying bitmap, saying imagesSame might be simpler (I think we use "same" in other places).

> Source/WebCore/page/animation/AnimationBase.cpp:697
> +       // If either is null, return false. If both are null, return true.

ibid.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list