[Webkit-unassigned] [Bug 74115] Web Inspector: XMLHttpRequest unsafe cross origin access errors for should show stack trace in console.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 8 13:20:33 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=74115





--- Comment #2 from Vsevolod Vlasov <vsevik at chromium.org>  2011-12-08 13:20:33 PST ---
> > Source/WebCore/bindings/js/JSXMLHttpRequestCustom.cpp:41
> > +#include "ScriptCallStack.h"
> 
> Please mind the alphabetic order
Done.

> > Source/WebCore/bindings/js/JSXMLHttpRequestCustom.cpp:118
> > +    impl()->setCallStack(createScriptCallStack(exec));
> 
> I think createScriptCallStack is a bad name for the method, sorry I missed the moment it got landed. You should explicitly state that the stack depth depends on the inspector front-end existence.
Renamed in a separate patch.

> > Source/WebCore/bindings/v8/V8Proxy.cpp:166
> > +    RefPtr<ScriptCallStack> stackTrace = createScriptCallStack(ScriptCallStack::maxCallStackSizeToCapture, true);
> 
> I don't see a corresponding change to JSC. Is this a part of a different change? You should probably limit the scope of this change to XHR and keep symmetry here.
Moved XHR part out to the separate bug.

> > Source/WebCore/xml/XMLHttpRequest.h:128
> > +    void setCallStack(PassRefPtr<ScriptCallStack>);
> 
> setLastSendCallStack ?
> 
> > Source/WebCore/xml/XMLHttpRequest.h:228
> > +    RefPtr<ScriptCallStack> m_callStack;
> 
> m_lastSendCallStack

Renamed to lastCallStack / setLastCallStack.
Please note that this field is not only used for send, it is also set in setRequestHeader

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list