[Webkit-unassigned] [Bug 74033] Refactoring: SpellChecker::requestCheckingFor should take SpellCheckRequest object

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 7 23:02:37 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=74033


MORITA Hajime <morrita at google.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #118325|review?                     |review-
               Flag|                            |




--- Comment #2 from MORITA Hajime <morrita at google.com>  2011-12-07 23:02:38 PST ---
(From update of attachment 118325)
View in context: https://bugs.webkit.org/attachment.cgi?id=118325&action=review

Basically looks fine. let's have one iteration.

> Source/WebCore/editing/SpellChecker.cpp:127
> +    request->setSequence(++m_lastRequestSequence);

Let us make sure that published id never conflict against the magic number. 
I know this will never happen in reality, but preventing it explicitly gives us more confidence.

> Source/WebCore/editing/SpellChecker.h:66
> +    Element* m_rootEditableElement;

Let's make this RefPtr to prevent possible dangling pointer access.

> Source/WebCore/editing/SpellChecker.h:78
> +    static PassRefPtr<SpellCheckRequest> createRequest(TextCheckingTypeMask, PassRefPtr<Range> checkingRange, PassRefPtr<Range> paragraphRange);

SpellCheckerRequest::create() is our standard way if there is no special reason.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list