[Webkit-unassigned] [Bug 73789] Need SSE optimization for SincResampler::Process()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 7 11:01:24 PST 2011


--- Comment #24 from Raymond Toy <rtoy at chromium.org>  2011-12-07 11:01:24 PST ---
(In reply to comment #23)
> > Then here we can say
> >   LOAD_DATA(load, load);
> > 
> > And below, we can have
> >   LOAD_DATA(loadu, load);
> >   LOAD_DATA(load, loadu);
> >   LOAD_DATA(loadu, loadu);
> > 
> > This makes it easy to see that they're all the same except whether we do aligned or unaligned loads.
> I think this would be much harder to follow than the existing code...

That's why I said "maybe add".  But it took me a bit of time to see what was different between the three branches.  Just one character difference...

I won't mind of the macro is not added.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list