[Webkit-unassigned] [Bug 73746] [GTK] Don't log document events in DRT
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Dec 3 10:42:19 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=73746
Martin Robinson <mrobinson at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #117766|review? |review+
Flag| |
--- Comment #3 from Martin Robinson <mrobinson at webkit.org> 2011-12-03 10:42:19 PST ---
(From update of attachment 117766)
View in context: https://bugs.webkit.org/attachment.cgi?id=117766&action=review
Seems good to me, but I have included a few minor style issue below.
> Source/WebKit/gtk/ChangeLog:21
> + (updateLoadingEventsResult): New, updates a global variable to
> + allow checking later on that the right signals were emmitted.
> + (documentLoadingEventCb): New, global listener for load-complete
> + and reload signals over the document object (the web area).
> + (testWebkitAtkDocumentLoadingEvents): New unit test, globally
> + connects to document-related signals and check they are properly
> + emitted when reloading the web view.
> + (main): Added new test.
This is nice.
> Source/WebKit/gtk/tests/testatk.c:495
> + if (!ATK_IS_OBJECT(axObject) || !signalName)
Is this an error if it doesn't happen. If so, would it be better to assert here instead?
> Source/WebKit/gtk/tests/testatk.c:506
> +
> +static gboolean documentLoadingEventCb(GSignalInvocationHint *signalHint,
> + guint numParamValues,
> + const GValue *paramValues,
> + gpointer data)
Please put these on one line to match WebKit style. The function should also be named documentLoadingEventCallback.
> Source/WebKit/gtk/tests/testatk.c:516
> + GSignalQuery signal_query;
signal_query -> signalQuery.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list