[Webkit-unassigned] [Bug 73585] Add a helper method to find whether an html page has custom page size styles.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 1 15:21:27 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=73585


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #117472|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #2 from Darin Adler <darin at apple.com>  2011-12-01 15:21:25 PST ---
(From update of attachment 117472)
View in context: https://bugs.webkit.org/attachment.cgi?id=117472&action=review

> Source/WebCore/dom/Document.cpp:1698
> +    RefPtr<RenderStyle> style = styleForPage(pageIndex);
> +    return style->pageSizeType() != PAGE_SIZE_AUTO;

This function should not be added. You can just put all the code at at the call site in WebFrameImpl.

> Source/WebKit/chromium/src/WebFrameImpl.cpp:1481
> +    return frame()->document()->hasCustomPageSizeStyle(pageIndex);

return frame->document()->styleForPage(pageIndex)->pageSizeType() != PAGE_SIZE_AUTO;

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list