[Webkit-unassigned] [Bug 67308] [Qt] TouchWebView crashes with segmentation fault
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Aug 31 14:17:17 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=67308
--- Comment #7 from Benjamin Poulain <benjamin at webkit.org> 2011-08-31 14:17:18 PST ---
(From update of attachment 105827)
View in context: https://bugs.webkit.org/attachment.cgi?id=105827&action=review
Looks like the right solution. Comments:
> Source/WebKit2/UIProcess/API/qt/qtouchwebview.cpp:67
> + if (availableSize.width() < 1 || availableSize.height() < 1)
> + return;
> +
Please use "size <= 0", which is a bit easier to read. Isn't there a QSize::isValid() or something like that?
You should also put that just after availableSize get its value. The span between the variable definition and its use is unnecessary.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list