[Webkit-unassigned] [Bug 66363] The executable allocator makes it difficult to free individual chunks of executable memory
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Aug 26 14:38:58 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=66363
--- Comment #16 from WebKit Review Bot <webkit.review.bot at gmail.com> 2011-08-26 14:38:58 PST ---
Attachment 105409 did not pass style-queue:
Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/JavaScriptCore/assembler/AssemblerBuffer.h:33: Alphabetical sorting problem. [build/include_order] [4]
Source/JavaScriptCore/runtime/InitializeThreading.cpp:33: Alphabetical sorting problem. [build/include_order] [4]
Source/JavaScriptCore/jit/JITOpcodes.cpp:45: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
Source/JavaScriptCore/jit/JIT.h:224: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
Source/JavaScriptCore/jit/JIT.h:277: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
Source/JavaScriptCore/jit/JIT.h:1037: The parameter name "globalData" adds no information, so it should be removed. [readability/parameter_name] [5]
Source/JavaScriptCore/wtf/MetaAllocator.cpp:282: Should have only a single space after a punctuation in a comment. [whitespace/comments] [5]
Source/JavaScriptCore/wtf/MetaAllocator.cpp:300: Should have only a single space after a punctuation in a comment. [whitespace/comments] [5]
Source/JavaScriptCore/wtf/RedBlackTree.h:159: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:230: An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement. [readability/control_flow] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:410: An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement. [readability/control_flow] [4]
Source/JavaScriptCore/jit/JITOpcodes32_64.cpp:43: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
Total errors found: 12 in 45 files
If any of these errors are false positives, please file a bug against check-webkit-style.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list