[Webkit-unassigned] [Bug 61140] [GTK] Add HTML5 Notifications support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 19 00:56:49 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=61140





--- Comment #41 from Alexandre Mazari <scaroo at gmail.com>  2011-08-19 00:56:48 PST ---
(In reply to comment #39)
> Created an attachment (id=104354)
 --> (https://bugs.webkit.org/attachment.cgi?id=104354&action=review) [details]
> Patch

So after a long hiatus, and a lot of going back and forth, here is an updated patch to introduce the html5 notifications support.
This patch now only contains the actual implementation of the spec.
The testing facilities (modifications of DRT, DRTSupport and LTC) were split in another patch, that might need some deeper review.

Updated since last patch:
- WebKitWebNotifications now inherits from the generated WebKitDOMNotification
- public api now exported using the WEBKIT_API macro
- the missing references to @self were added to the documentation
- removed the GdkPixbuf cache for the icons
- usage of Image::getGdkPixbuf
- Made _get_direction returns a GtkTextDirection
- added convenience api for _to_string, _equals and _replaces
- hopefully fixed style issues
- use ASSERT instead of g_assert
- rename _url to _uri

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list