[Webkit-unassigned] [Bug 66363] The executable allocator makes it difficult to free individual chunks of executable memory
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Aug 18 15:37:42 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=66363
--- Comment #10 from WebKit Review Bot <webkit.review.bot at gmail.com> 2011-08-18 15:37:42 PST ---
Attachment 104411 did not pass style-queue:
Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Last 3072 characters of output:
space between // and comment [whitespace/comments] [4]
Source/JavaScriptCore/wtf/MetaAllocator.cpp:422: Should have a space between // and comment [whitespace/comments] [4]
Source/JavaScriptCore/wtf/MetaAllocator.h:34: Alphabetical sorting problem. [build/include_order] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:38: Alphabetical sorting problem. [build/include_order] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:45: Should have only a single space after a punctuation in a comment. [whitespace/comments] [5]
Source/JavaScriptCore/wtf/RedBlackTree.h:161: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:164: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:166: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:171: More than one command on the same line in if [whitespace/parens] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:180: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:182: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:184: More than one command on the same line in if [whitespace/parens] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:185: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:235: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:232: An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement. [readability/control_flow] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:240: More than one command on the same line in if [whitespace/parens] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:353: Missing space before ( in if( [whitespace/parens] [5]
Source/JavaScriptCore/wtf/RedBlackTree.h:353: Extra space after ( in if [whitespace/parens] [5]
Source/JavaScriptCore/wtf/RedBlackTree.h:374: Missing space before ( in if( [whitespace/parens] [5]
Source/JavaScriptCore/wtf/RedBlackTree.h:374: Extra space after ( in if [whitespace/parens] [5]
Source/JavaScriptCore/wtf/RedBlackTree.h:415: One line control clauses should not use braces. [whitespace/braces] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:412: An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement. [readability/control_flow] [4]
Source/JavaScriptCore/wtf/RedBlackTree.h:423: More than one command on the same line in if [whitespace/parens] [4]
Source/JavaScriptCore/jit/JITOpcodes32_64.cpp:43: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5]
Source/JavaScriptCore/wtf/MetaAllocatorHandle.h:42: The parameter name "allocator" adds no information, so it should be removed. [readability/parameter_name] [5]
Total errors found: 76 in 42 files
If any of these errors are false positives, please file a bug against check-webkit-style.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list