[Webkit-unassigned] [Bug 66083] [chromium] Split LayerTextureUpdater into main thread / compositor thread versions

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 11 15:32:23 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=66083





--- Comment #9 from James Robinson <jamesr at chromium.org>  2011-08-11 15:32:23 PST ---
(In reply to comment #6)
> (In reply to comment #4)
> > why does ContentLayerChromium own the CCLayerTextureUpdaterImpl?  That seems quite wrong.
> 
> See bug 66074.  LayerTilerChromium::updateRect(LayerTextureUpdater*) is called via LayerRendererChromium::updateCompositorResources which iterates over the LayerChromium tree.  So, until that pass is changed to iterate over the CC layer tree, it can't be owned by the CC layer.
> 
> I personally think that change can be deferred.  There's enough in flux here as it is.

Hm, I thought the plan was to change uploading as well?  I'm OK with doing that separately, but then the naming is wrong.  The current model is that updateCompositorResources() operates on the main thread data structures (LayerChromium tree).  So the plan is to split up the uploading into multiple classes while leaving it on the LayerChromium tree, and then later move part of the uploading to the CCLayerImpl side?  If so I'd suggest that we don't use the CC*Impl naming convention until the second step actually happens.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list