[Webkit-unassigned] [Bug 65799] String replace with the empty string means string removal

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 5 17:34:29 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=65799


Sam Weinig <sam at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #103133|review?                     |review+
               Flag|                            |




--- Comment #3 from Sam Weinig <sam at webkit.org>  2011-08-05 17:34:29 PST ---
(From update of attachment 103133)
View in context: https://bugs.webkit.org/attachment.cgi?id=103133&action=review

>> Source/JavaScriptCore/runtime/StringPrototype.cpp:271
>> +    PassRefPtr<StringImpl> impl = StringImpl::tryCreateUninitialized(totalLength, buffer);
> 
> Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]

This is copy and pasted, but very wrong.  Please us a RefPtr and fix the other spot.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list