[Webkit-unassigned] [Bug 56397] Suppress modal JavaScript/HTML dialogs during unload events
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Apr 9 14:57:21 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=56397
Ryosuke Niwa <rniwa at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #88926|review? |review-
Flag| |
--- Comment #11 from Ryosuke Niwa <rniwa at webkit.org> 2011-04-09 14:57:20 PST ---
(From update of attachment 88926)
View in context: https://bugs.webkit.org/attachment.cgi?id=88926&action=review
Please separate changes to the existing tests because there's no reason they should be in the same patch.
> Source/WebCore/page/Chrome.cpp:209
> +static inline bool canRunModalDuringPageDismissal()
> +{
> +#if PLATFORM(CHROMIUM)
> + return false;
> +#else
> + return true;
> +#endif
> +}
I don't think this is the right way to do it. Since we already have willRunModalDialogDuringPageDismissal on chrome client, we should rename it to shouldRunModalDialogDuringPageDismissal and have it return a boolean value. I know that we want all ports to eventually disallow modal dialogs but that's not the case at least for now so it seems more natural to have chrome client decide it.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list