[Webkit-unassigned] [Bug 59596] Web Inspector: Move Resources Panel search to backend

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 28 10:43:17 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=59596


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #91499|review?                     |review-
               Flag|                            |




--- Comment #8 from Pavel Feldman <pfeldman at chromium.org>  2011-04-28 10:43:17 PST ---
(From update of attachment 91499)
View in context: https://bugs.webkit.org/attachment.cgi?id=91499&action=review

> Source/WebCore/inspector/InspectorPageAgent.cpp:424
> +        result.append("[");

"^" will convert into [^], will it work?

> Source/WebCore/inspector/InspectorPageAgent.cpp:440
> +    while (start < content.length() && (position = regex.match(content, start, &matchLength)) != -1) {

Could you break this down for better readability?

> Source/WebCore/inspector/InspectorPageAgent.cpp:458
> +void InspectorPageAgent::searchInResources(ErrorString* errorString, const String& text, const bool* const optionalCaseSensitive, const bool* const optionalIsRegex, RefPtr<InspectorArray>* object)

Order of methods in the .cpp should match the one in .h when possible.

> Source/WebCore/inspector/InspectorPageAgent.cpp:469
> +        const CachedResourceLoader::DocumentResourceMap& allResources = frame->document()->cachedResourceLoader()->allCachedResources();

It would be great if we could extract cached resource traversal logic into one place. I think I mentioned it earlier.

> Source/WebCore/inspector/InspectorPageAgent.cpp:474
> +            switch (InspectorPageAgent::cachedResourceType(*cachedResource)) {

Ditto. Can we extract method for this logic (and use ::resourceContent(cachedResource))?

> Source/WebCore/inspector/front-end/ResourcesPanel.js:690
> +        function searchInEditedResource(treeElement)

Lets add it in a separate patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list