[Webkit-unassigned] [Bug 57944] [GTK] Implement WKView with a common widget that can be used by both C and gtk APIs

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 27 00:14:39 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57944


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mrobinson at webkit.org




--- Comment #13 from Martin Robinson <mrobinson at webkit.org>  2011-04-27 00:14:39 PST ---
(In reply to comment #12)
> (In reply to comment #11)
> > (From update of attachment 89758 [details] [details])
> > I'm going to r- this patch. On discussing this with Alex, it seems that we should be able to leave our current WebKit2 C-API design mostly unchanged.
> 
> what design?

This patch does a lot of different things at once:

1. It moves the WebKitViewWidget class to a different directory and gives it a different name.
2. It moves a lot of the logic from the PageClient / WebKit into the WebKitViewWidget. 
3. It changes the interface that's exposed in the existing API. Instead of a WKViewRef being an opaque C++ class pointer, it's now a GtkWidget.

I think that some of these things are a good idea and I'm not yet convinced about others. Can you split this patch up a bit so we can discuss each bit separately? First let's move the WebKitViewWidget GObject. Then we can approach each of the other tasks separately.

In particular, I want to move the logic for handling key bindings to a separate class so WebKit1 and WebKit2 can share it. Once I finish that, the second part of this patch will be much smaller.

As for the third point, I feel we should discuss it and reach consensus before making the change.

> what's wrong with my alternative?

It's hard to answer this question, because there are multiple things happening in your patch. It took me quite a while to review it because it was so large. Would you be willing to follow the approach to splitting this patch I suggested above? It will be easier for me and perhaps others to make decisions about your suggested changes if orthogonal parts are in separate patches and bugs. First you could just move and rename the WebKitViewWidget and we could go from there on different bugs.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list