[Webkit-unassigned] [Bug 54439] [EFL] New API for executing Editor Commands: InsertText, InsertImage.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 26 16:42:18 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=54439





--- Comment #15 from Lucas De Marchi <demarchi at webkit.org>  2011-04-26 16:42:17 PST ---
(In reply to comment #0)
> Created an attachment (id=82425)
 --> (https://bugs.webkit.org/attachment.cgi?id=82425&action=review) [details]
> patch
> 
> I'd like to add new functionalities to be executed by EditorCommand - InsertText, InsertImage.
> I decided to do it in a different way than previous commands: "SelectWord", "SelectLine" etc. 
> I believe that having one function for all commands is much better than tens of similar functions 
> (what is possible as EditorCommand has a lot of commands defined).
> 
> Due to this fact I was also thinking about replacing existing functions (listed below) by additional enums in Ewk_Editor_Command
> but I'm not sure whether removing API is a good idea, what do you think?
> 
> List of existing editor commands:
> EAPI Eina_Bool    ewk_view_select_none(Evas_Object *o);
> EAPI Eina_Bool    ewk_view_select_all(Evas_Object *o);
> EAPI Eina_Bool    ewk_view_select_paragraph(Evas_Object *o);
> EAPI Eina_Bool    ewk_view_select_sentence(Evas_Object *o);
> EAPI Eina_Bool    ewk_view_select_line(Evas_Object *o);
> EAPI Eina_Bool    ewk_view_select_word(Evas_Object *o);


IMO it's ok to remove these too, and merge with this new one that you implemented. Feel free to add this later.

thanks

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list