[Webkit-unassigned] [Bug 54752] [EFL] Soup authentication feature implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 26 16:08:38 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=54752





--- Comment #10 from Lucas De Marchi <demarchi at webkit.org>  2011-04-26 16:08:37 PST ---
(From update of attachment 82967)
View in context: https://bugs.webkit.org/attachment.cgi?id=82967&action=review

Overall I think most of this code should be shared somehow with gtk. There's no need to use g_slice_new0 / g_slice_free. If this indeed used, it should not be inside ewk/.

> Source/WebKit/efl/ewk/ewk_main.h:48
> +/**
> + * Set callback to be called when authentication is required.
> + */
> +EAPI void ewk_show_auth_dialog_callback_set(ewk_show_auth_dialog_callback);

When you move to the new file, remember to keep namespaces clean. E.g.: this function should be named "ewk_auth_..."

> Source/WebKit/efl/ewk/ewk_main.h:57
> +/**
> + * Calls authentication method for setting credentials.
> + *
> + * @param username username
> + * @param password user password
> + * @param data soup authentication data
> + */
> +EAPI void ewk_auth_credentials_set(char* username, char* password, void* data);

This one is right. Make the others like this.

> Source/WebKit/efl/ewk/ewk_soup_authentication.cpp:3
> +/*
> +    Copyright (C) 2009-2011 Samsung Electronics
> +

Since this is based on the GTK port, you probably need to keep their copyrights. And here it's only 2011 for yours.

> Source/WebKit/efl/ewk/ewk_soup_authentication.h:23
> +
> +#include "ewk_eapi.h"

Remember that this is gone now.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list