[Webkit-unassigned] [Bug 44329] SH4 JIT SUPPORT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 8 10:30:29 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=44329


Oliver Hunt <oliver at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #88821|review?                     |review-
               Flag|                            |




--- Comment #121 from Oliver Hunt <oliver at apple.com>  2011-04-08 10:30:27 PST ---
(From update of attachment 88821)
View in context: https://bugs.webkit.org/attachment.cgi?id=88821&action=review

r- due to naming issue, almost there.

> Source/JavaScriptCore/jit/JIT.h:710
> +#define END_UNINTERRUPTED_SEQUENCE2(name, dst) do { endUninterruptedSequence(name ## InstructionSpace, name ## ConstantSpace, dst); } while (false)

This is a bad name, if anything END_UNINTERRUPTED_SEQUENCE_FOR_PUT might be better?

> Source/JavaScriptCore/jit/JITInlineMethods.h:143
> +ALWAYS_INLINE void JIT::endUninterruptedSequence(int insnSpace, int constSpace, int dst)

Does the arm build work with this change?  afaict it should fail due to dst being unused.

You could put UNUSED_PARAM(dst) in the function to deal with that.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list