[Webkit-unassigned] [Bug 57849] [Chromium] Add WebKit API to query and request unified offline-storage quota

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 7 20:50:22 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57849





--- Comment #16 from Kinuko Yasuda <kinuko at chromium.org>  2011-04-07 20:50:22 PST ---
(From update of attachment 88582)
Thanks for reviewing,

View in context: https://bugs.webkit.org/attachment.cgi?id=88582&action=review

>> Source/WebKit/chromium/public/WebStorageQuotaCallbacks.h:45
>> +    virtual void wasGrantedStorageQuota(unsigned long long grantedQuotaInBytes) = 0;
> 
> you're going to hate me for suggesting another change here, but maybe
> didGrantStorageQuota would be an even better name.  that just occurred
> to me.

Ok that sounds better... :) I'll just replace the method name and will submit, if the change doesn't affect your r+.

>> Source/WebKit/chromium/public/WebStorageQuotaError.h:38
>> +    WebStorageQuotaErrorOk = 0,
> 
> do you need the "ok" value?  i can't imagine didFail being called with this value.

Sounds true, will drop it.

>> Source/WebKit/chromium/public/WebStorageQuotaError.h:40
>> +    WebStorageQuotaErrorSecurity = 18,
> 
> it is not very obvious what ErrorSecurity and ErrorAbort mean.  i think ErrorAbort
> will be used whenever the operation could not complete because we are shutting down.
> what does ErrorSecurity mean?
> 
> maybe the name could be improved or maybe a comment could be added or both.

For now I will just drop QuotaErrorSecurity until I find a proper usage.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list