[Webkit-unassigned] [Bug 57922] Implement Background and Mask based properties in CSSStyleApplyProperty

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 7 16:38:54 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57922





--- Comment #4 from Luke Macpherson <macpherson at chromium.org>  2011-04-07 16:38:54 PST ---
(In reply to comment #2)

Thanks Eric. I pretty much agree with you on all points.

> (From update of attachment 88372 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=88372&action=review
> 
> This seems sane.  Are you sure we can't delete the macros?  It's feels awkward having two (possibly divergent) ways to do this same thing.

Almost there, just a few properties left to remove before this can happen.

> > Source/WebCore/css/CSSStyleApplyProperty.cpp:226
> > +            (selector->*m_mapFill)(m_propertyId, currChild, value);
> 
> I find this calling convention very ugly.  We may want to write wrappers which take a "selector" argument and know how to do the ->*m_mapfill call.  Or maybe I'll just get used to the convention.

I think CSSStyleSelector::mapFill* should be moved into CSSStyleApplyProperty, but I haven't been brave enough to do that refactoring yet. These look like they need re-writing anyway as there appears to be a lot of common code between them. I'll file a bug for future cleanup.

> > Source/WebCore/css/CSSStyleApplyProperty.cpp:275
> > +    setPropertyValue(CSSPropertyWebkitBackgroundSize, CSSPropertyBackgroundSize);
> 
> Seems we may eventually rename this to "setValueApplier?" or similar.  setPropertyValue makes it sound like we're some css property on an element.

Agreed. Will do.

> > Source/WebCore/css/CSSStyleSelector.cpp:-3655
> > -        HANDLE_BACKGROUND_VALUE(clip, Clip, value)
> 
> Can we delete these macros now?

Not quite yet, but soon - there are some expanding properties that need to move from CSSStyleSelector to CSSStyleApplyProperty before we can do that. I plan to do it shortly but in the interests of making small incremental changes left it out of this CL.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list