[Webkit-unassigned] [Bug 57088] Refactoring: Editor::TextCheckingOptions should be replaced with TextCheckingType

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 7 03:51:30 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57088





--- Comment #5 from Ryosuke Niwa <rniwa at webkit.org>  2011-04-07 03:51:28 PST ---
(From update of attachment 88562)
View in context: https://bugs.webkit.org/attachment.cgi?id=88562&action=review

> Source/WebCore/editing/Editor.cpp:2226
> +    bool shouldMarkSpelling = textCheckingTypes.spelling();
> +    bool shouldMarkGrammar = textCheckingTypes.grammar();
> +    bool shouldPerformReplacement = textCheckingTypes.replacement();
> +    bool shouldShowCorrectionPanel = textCheckingTypes.correctionPanel();
> +    bool shouldCheckForCorrection = shouldShowCorrectionPanel || textCheckingTypes.correction();

I think these member functions should be named as isSpelling, isGrammar, etc...

> Source/WebCore/editing/Editor.cpp:3623
> -TextCheckingTypeMask Editor::textCheckingTypeMaskFor(TextCheckingOptions textCheckingOptions)
> +TextCheckingTypes Editor::addTextCheckSettings(const TextCheckingTypes& textCheckingTypes)

I don't think this function name makes sense since you're not modifying the original textCheckingTypes.  Something like resolveReplacedTextCheckingType might work.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list