[Webkit-unassigned] [Bug 57964] Fast path for parsing simple CSS values

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 6 11:57:24 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57964





--- Comment #3 from Simon Fraser (smfr) <simon.fraser at apple.com>  2011-04-06 11:57:25 PST ---
(From update of attachment 88473)
View in context: https://bugs.webkit.org/attachment.cgi?id=88473&action=review

> Source/WebCore/css/CSSParser.cpp:262
> +static bool isSimpleColorPropertyID(int id)

Make inline?

> Source/WebCore/css/CSSParser.cpp:352
> +static bool parseSimpleDimensionValue(CSSMutableStyleDeclaration* declaration, int id, const String& string, bool important, bool strict)

Say Length instead of DimensionValue?

> Source/WebCore/css/CSSParser.cpp:390
> +bool CSSParser::parseValue(CSSMutableStyleDeclaration* declaration, int id, const String& string, bool important, bool strict)

Please rename 'id' to 'propId' or 'propertyId'.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list