[Webkit-unassigned] [Bug 57955] New: [GTK] Do not reference AccessibilityRenderObject from platform dependent code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 6 08:55:34 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57955

           Summary: [GTK] Do not reference AccessibilityRenderObject from
                    platform dependent code
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Keywords: Gtk
          Severity: Normal
          Priority: P2
         Component: Accessibility
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: msanchez at igalia.com
                CC: cfleizach at apple.com


Currently, many explicit references to AccessibilityRenderObject are being carried out in platform dependant code (that is, the GTK a11y wrapper and its related files), which shouldn't be needed if we had some methods virtually defined in AccessibilityObject.h, and properly overriden in its subclases.

More specifically, the methods that we would need in AccessibilityObject.h to be able to get rid of those explicit references in the GTK wrapper would be the following two:

    virtual RenderObject* renderer() const { return 0; }
    virtual AccessibilityObject* correspondingLabelForControlElement() const { return 0; }

Once defined, a lot of code could be simplified, and lines '#include "AccessibilityRenderObject.h"' removed from those .cpp files inside Source/WebCore/accessibility/gtk

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list