[Webkit-unassigned] [Bug 57851] Bundle lineLeftOffset and lineRightOffset as a class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 6 05:37:22 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57851





--- Comment #3 from Eric Seidel <eric at webkit.org>  2011-04-06 05:37:21 PST ---
(From update of attachment 88242)
View in context: https://bugs.webkit.org/attachment.cgi?id=88242&action=review

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:80
> +            extraWidth += borderPaddingMarginStart(toRenderBoxModelObject(parent));

I might have even added a RenderBoxModelObject* parentAsBoxModelObject local.  I wonder it that's always true for SVG Text.  I think we still use a RenderBoxModel object to hol the SVG text.  I think we have to since we haven't split LineBoxTree out into its own class.

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:598
> +static inline bool isWhitespace(UChar character, bool shouldPreserveNewline)

Might want a more specific name relating to what spec defines this whitespace, etc.  isCSS3WhiteSpace for example.  isCSSSkipableWhitespace, or wahtever.

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:2279
> +bool RenderBlock::positionNewFloatOnLine(FloatingObject* newFloat, FloatingObject* lastFloatFromPreviousLine, bool firstLine, LineOffsets& lineOffsets)

I would have preferred that you moved this code in a separate patch.  Makes it difficult to read this diff.

I'm slightly lost in all the changes you're making.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list