[Webkit-unassigned] [Bug 57922] Implement Background and Mask based properties in CSSStyleApplyProperty

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 6 05:32:15 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=57922





--- Comment #2 from Eric Seidel <eric at webkit.org>  2011-04-06 05:32:15 PST ---
(From update of attachment 88372)
View in context: https://bugs.webkit.org/attachment.cgi?id=88372&action=review

This seems sane.  Are you sure we can't delete the macros?  It's feels awkward having two (possibly divergent) ways to do this same thing.

> Source/WebCore/css/CSSStyleApplyProperty.cpp:226
> +            (selector->*m_mapFill)(m_propertyId, currChild, value);

I find this calling convention very ugly.  We may want to write wrappers which take a "selector" argument and know how to do the ->*m_mapfill call.  Or maybe I'll just get used to the convention.

> Source/WebCore/css/CSSStyleApplyProperty.cpp:275
> +    setPropertyValue(CSSPropertyWebkitBackgroundSize, CSSPropertyBackgroundSize);

Seems we may eventually rename this to "setValueApplier?" or similar.  setPropertyValue makes it sound like we're some css property on an element.

> Source/WebCore/css/CSSStyleSelector.cpp:-3655
> -        HANDLE_BACKGROUND_VALUE(clip, Clip, value)

Can we delete these macros now?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list