[Webkit-unassigned] [Bug 56855] [GTK] Unify accessibility role names in DRT for GTK and Mac platforms

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 5 07:15:18 PDT 2011


--- Comment #5 from Mario Sanchez Prada <msanchez at igalia.com>  2011-04-05 07:15:19 PST ---
(In reply to comment #4)
> > > Have a method like isMac() isGTK() so we can conditionalize in the test
> > 
> > You mean in DRT, right? so we can actually use that isMac() or isGTK() in the 
> > Javascript code when calling to the shouldBe() functions?
> > 
> yea that would mean just one test, maybe different expectations, but maybe not 
> always.

Another thing I thought of while working on bug 57826 (and which I actually used in the currently proposed patch in there) is not to use role names at all in the tests, that is in the HTML files.

Instead, why not just dumping the role names directly in the output and let the actual check to be done in the expected files? At least that way we would only need one HTML file in some cases

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list