[Webkit-unassigned] [Bug 54969] [Chromium] Implement WebKit methods to assist with Cocoa NSTextInput implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 4 21:25:56 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=54969





--- Comment #23 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2011-04-04 21:25:55 PST ---
(From update of attachment 86977)
View in context: https://bugs.webkit.org/attachment.cgi?id=86977&action=review

> Source/WebKit/chromium/public/mac/WebTextHelper.h:44
> +class WebTextHelper {

nit: a more specific class name would be nice.

> Source/WebKit/chromium/public/mac/WebTextHelper.h:46
> +    explicit WebTextHelper(WebFrame*);

why bother instantiating this class?  why not just make substringInRange be
a static method that takes a WebFrame pointer?

> Source/WebKit/chromium/public/mac/WebTextHelper.h:50
> +    WebString substringInRange(size_t location, size_t length);

please remember to annotate entry points with WEBKIT_API.  even though it is
probably not strictly necessary for the OSX build, it is still nice to be
consistent with WEBKIT_API usage.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list