[Webkit-unassigned] [Bug 44700] IDBObjectStore::get should run in a transaction.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 20 17:28:31 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=44700





--- Comment #16 from Andrei Popescu <andreip at google.com>  2010-09-20 17:28:31 PST ---
(In reply to comment #13)
> (From update of attachment 68067 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=68067&action=review
> 
> > LayoutTests/storage/indexeddb/objectstore-basics-expected.txt:116
> > +db.transaction()
> 
> hu?   does this work?  Don't you need to save it to a variable?  ideally use db.transaction() too?
>

Yes, you're reading the expected output, not the actual test.

> 
> > LayoutTests/storage/indexeddb/transaction-get.html:18
> > +        debug("Accessing a committed transaction should throw");
> 
> This should be a failure, not a debug
> 
> It's ok to check in a failing result if that's what it should be.
> 
> > LayoutTests/storage/indexeddb/transaction-get.html:22
> > +        shouldBe('exc.code', '9');
> 
> use the constant
> 
> > LayoutTests/storage/indexeddb/transaction-get.html:27
> > +function nonExistingKey() {
> 
> all functions should put { on the next line
> 
> > LayoutTests/storage/indexeddb/transaction-get.html:41
> > +    transaction.onabort = unexpectedErrorCallback;
> 
> newline after this maybe?
> 
> > LayoutTests/storage/indexeddb/transaction-get.html:44
> > +    var result = store.get('myKey');
> 
> put in evalAndLog
> 
> > LayoutTests/storage/indexeddb/transaction-get.html:49
> > +    var emptyResult = store.get('nonExistingKey');
> 
> put at the end of gotValue (yes, this is supposed to work, but that'll make it easier to read)
> 
> > LayoutTests/storage/indexeddb/transaction-get.html:80
> > +function test() {
> 
> From now on, please write new tests from top down in terms of execution and function names saying what just happened, please.
> 

These were added in the previous patch. Will look and fix tomorrow.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list