[Webkit-unassigned] [Bug 45944] Update percent-image-height layout test to include additional parent element positioning modes.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 16 21:37:04 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45944


Ojan Vafai <ojan at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #67880|review?                     |review-
               Flag|                            |




--- Comment #3 from Ojan Vafai <ojan at chromium.org>  2010-09-16 21:37:04 PST ---
(From update of attachment 67880)
View in context: https://bugs.webkit.org/attachment.cgi?id=67880&action=prettypatch

> LayoutTests/fast/images/percent-height-image.html:34
> +    function runTests() {

Here and below: WebKit style is to put the opening bracket on the next line. Not all the JS code follows the style since there's no formal WebKit JS style, but we're trying to push it in that direction to make it match C++.

> LayoutTests/fast/images/percent-height-image.html:43
> +        document.querySelector("body").className = name;

how about:
document.getElementById('parent').className = name.

Then  you can change the selectors in the CSS above to just have the className. I think that would make the test a bit more readable.

> LayoutTests/fast/images/percent-height-image.html:48
> +            log(className + " FAIL: image height was " + actual + " expected " + expected);

Indentation is off.

> LayoutTests/fast/images/percent-height-image.html:56
> +    Tests that an image with height 100% inside a floated div keeps its intrinsic height.<br/>

This description is no longer accurate.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list