[Webkit-unassigned] [Bug 45585] Add zoom support to WebKit2 API
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Sep 10 23:20:26 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=45585
--- Comment #4 from mitz at webkit.org 2010-09-10 23:20:26 PST ---
(From update of attachment 67290)
View in context: https://bugs.webkit.org/attachment.cgi?id=67290&action=prettypatch
> WebKit2/Shared/CoreIPCSupport/WebPageMessageKinds.h:57
> + SetPageZoomFactor,
> + SetTextZoomFactor,
> + SetPageAndTextZoomFactors,
Please sort. Better yet, why not eliminate SetPageZoomFactor and SetTextZoomFactor and always send SetPageAndTextZoomFactors?
> WebKit2/UIProcess/WebPageProxy.cpp:403
> + m_textZoomFactor = zoomFactor;
> + process()->send(WebPageMessage::SetTextZoomFactor, m_pageID, CoreIPC::In(m_textZoomFactor));
Should this return early and save the IPC if m_textZoomFactor is already equal to zoomFactor?
> WebKit2/UIProcess/API/C/WKPage.cpp:156
> +float WKPageGetTextZoomFactor(WKPageRef pageRef)
Why float and not double?
> WebKitTools/MiniBrowser/mac/BrowserWindowController.m:168
> +#define kWKDefaultMinimumZoomFactor (.5f)
> +#define kWKDefaultMaximumZoomFactor (3.0f)
> +#define kWKDefaultZoomFactorRatio (1.2f)
Why do these have a WK prefix if they’re not defined in WebKit?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list