[Webkit-unassigned] [Bug 45522] Remove unnecessary constraint in WebCore of choosing either text zoom or full page zoom.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 10 16:02:54 PDT 2010


--- Comment #13 from Sam Weinig <sam at webkit.org>  2010-09-10 16:02:53 PST ---
(In reply to comment #11)
> (In reply to comment #10)
> > we would probably end up doing a little too much work if we called both setPageZoomFactor and setTextZoomFactor in a row, so I have added a function which can change both at once if that is what is wanted.
> Really? Are you sure?
> There are other changes someone might make at the same time too, so I don’t see why we have to gang these two together. I think having a function to change both at once is not worthwhile, and poor factoring. Unless it’s measurably better for performance.

Well, both end up calling document->recalcStyle(Node::Force);, which Dan tells me can be expensive.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list