[Webkit-unassigned] [Bug 45071] Only intercept ESC key press when autocorrection UI is visible.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Sep 9 10:09:09 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=45071
--- Comment #3 from mitz at webkit.org 2010-09-09 10:09:09 PST ---
(From update of attachment 66555)
View in context: https://bugs.webkit.org/attachment.cgi?id=66555&action=prettypatch
> WebCore/editing/Editor.cpp:2822
> +bool Editor::isCorrectionUIShown()
Is there a reason for calling it “correction UI” here when everywhere else it’s “correction panel”? I would name this (and the client method) isShowingCorrectionPanel(), so that editor->isShowingCorrectionPanel() reads like a sentence with editor being the subject.
> WebCore/editing/EditorCommand.cpp:1125
> +static bool supportedDismissCorrectionUI(Frame* frame, EditorCommandSource)
> +{
> + return frame->editor()->isCorrectionUIShown();
> +}
Perhaps in addition to checking this we should still limit to menu and key binding? I don’t think we want to expose this through the execCommand DOM interface, for example.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list