[Webkit-unassigned] [Bug 45114] Web Inspector: show status message below call stack when debugger is paused

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 9 09:45:41 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45114





--- Comment #8 from Joseph Pecoraro <joepeck at webkit.org>  2010-09-09 09:45:41 PST ---
Here is how I would have written them. Note I have added "a" or "an" to
most of the statements. I guess this could be personal taste though.


> * "Paused on debugger statement."
    "Paused on a `debugger` statement."
Give 'debugger' a special format?


> * "Paused on javascript breakpoint."
    "Paused on breakpoint #." or "Paused on a breakpoint."

JavaScript in text displayed to the user should always be "JavaScript". However
in this case I don't think the word is needed, since we know we are in JavaScript.


> * "Paused on exception."
    "Paused on an exception." or "Paused on a <exception or error type>."

An example of the latter being: "Paused on a TypeError exception."


> * "Paused on uncaught exception."
    "Paused on an uncaught exception." or "Paused on an uncaught <exception or error type>."


>  DOM events:
> * "Paused on "Subtree Modified" breakpoint set on <node>, because new child was added to it's descendant <target>."
> * "Paused on "Subtree Modified" breakpoint set on <node>, because new child was added to that node."
    "Paused on a ..., because the new child was added to its ..."
               ^              ^^^                        ^^^

"It's" becomes "it is". "Its" means ownership. This is a weird case in English, because
normally the apostrophe means ownership.

> * "Paused on "Subtree Modified" breakpoint set on <node>, because because it's descendant <target> was removed."

  No double "because". "It's" again.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list