[Webkit-unassigned] [Bug 44127] [chromium] Thumbnails not generated for GPU Rendered Pages

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 8 17:36:47 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=44127





--- Comment #59 from Vangelis Kokkevis <vangelis at chromium.org>  2010-09-08 17:36:47 PST ---
(From update of attachment 66911)
View in context: https://bugs.webkit.org/attachment.cgi?id=66911&action=prettypatch

You make a good point about the extra allocations and unnecessary copies that would be introduced if we used an intermediate ImageBuffer and ImageData to store the pixels.  However, since this code won't be called too often (only for thumbnailing and printing?) it's probably not worth worrying about it. WebKit allocates and destroys GraphicsContexts on a whim every time it renders a page....  I think the reduced code size and complexity will more than make up for it.

> WebKit/chromium/src/WebViewImpl.cpp:117
> +#include <wtf/OwnArrayPtr.h>
WK uses quotes instead of angle brackets for includes.

> WebKit/chromium/src/WebViewImpl.cpp:998
> +    bitmap.eraseColor(SkColorSetARGB(0, 0, 0, 0));
Since this is a one-liner, it's probably better to just call it directly instead of making a function for it.

> WebKit/chromium/src/WebViewImpl.cpp:1046
> +                clearSkBitmap(bitmap);
Do we really have to worry about the canvasResize not being able to initialize? What would make it fail? Maybe the else path can be removed.

> WebKit/chromium/src/WebViewImpl.cpp:1061
> +    CGContextClearRect(bitmap,
same as above. probably not worth making a separate function for it.

> WebKit/chromium/src/WebViewImpl.cpp:1090
> +                clearCGBitmap(bitmap);
Again, do we have to worry about the failing to create the temporary bitmap?

> WebKit/chromium/src/WebViewImpl.h:48
> +#include <IntRect.h>
Quotes instead of angle brackets

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list