[Webkit-unassigned] [Bug 45367] New: Find a better word than optional for getters that can return null
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 7 22:59:12 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=45367
Summary: Find a better word than optional for getters that can
return null
Product: WebKit
Version: 528+ (Nightly build)
Platform: PC
OS/Version: Mac OS X 10.5
Status: NEW
Severity: Normal
Priority: P2
Component: WebCore Misc.
AssignedTo: webkit-unassigned at lists.webkit.org
ReportedBy: sam at webkit.org
We should think up a better word than optional for getters that can return null (see Element::dataset and Element::optionalDataset). This word has been used in a few places, but we should do better. Some ideas from Maciej include:
nullableDataset? maybeDataset? datasetIfExists? datasetNoCreate?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list