[Webkit-unassigned] [Bug 44958] Add support for autocorrection UI on Mac OS X.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 1 06:38:43 PDT 2010


jpu at apple.com changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED

--- Comment #17 from jpu at apple.com  2010-09-01 06:38:43 PST ---

> > WebCore/ChangeLog:21
> > +        (WebCore::Editor::markAllMisspellingsAndBadGrammarInRanges): Added an argument to indicate whether we want to show autocorrection UI. Added code to show autocorrection UI if it is necessary. Replaced all four boolean arguments with enum to improve readability.
> I think a single enum-based bitfield would have been even better. Please wrap this long line.

Replaced all boolean arguments with a bitfield.

> > WebCore/editing/Editor.cpp:2701
> > +            if (doReplacement) {
> I think I may have misled you about this in an earlier review, but it seems like this block could now be entered in cases where previously it wasn’t, because the result-type check and the canEdit() and shouldInsertText() checks aren’t applied here.

Yes, I should have reviewed your review more closely. :)

> > WebCore/platform/graphics/GraphicsContext.h:284
> > +        void drawLineForTextChecking(const IntPoint&, int width, TextCheckingLineStyle);
> > +#else
> >          void drawLineForMisspellingOrBadGrammar(const IntPoint&, int width, bool grammar);
> > -
> > +#endif
> It’s really bad the have different GraphicsContext methods for Mac and all the other ports. It shouldn’t be hard to blindly change all other ports to adopt the new method.

This is indeed unwieldy given the different platforms we need to build on. I have replaced all calls to drawLineForMisspellingOrBadGrammar() with drawLineForTextChecking().

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list