[Webkit-unassigned] [Bug 48357] [GTK] Add the GtkScrollablePolicy property to the webview

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 27 04:03:06 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=48357





--- Comment #5 from Alejandro G. Castro <alex at igalia.com>  2010-10-27 04:03:06 PST ---
(In reply to comment #4)
> (From update of attachment 71925 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=71925&action=review
> 
> Looks good, but I have a couple concerns.
> 
> > WebKit/gtk/webkit/webkitprivate.h:161
> > +        guint hscroll_policy : 1;
> > +        guint vscroll_policy : 1;
> > +
> 
> I think I'd prefer these to be named horizontalScrollingPolicy and verticalScrollingPolicy.

Changed.

> Why the use of bitfields here? I'm a little worried about such a rarely used feature causing issues with other compilers. Is it possible to make these of type GtkScrollablePolicy instead of guint?

It is the usual way in gtk, it is basically how it is defined in all the other gtk widgest in the library so I assume it is safe enough for us. But yeah, I guess it is just about making smaller structs. I'm ok using the enum because we are not using the bitwise any other place.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list