[Webkit-unassigned] [Bug 47365] getTextAtOffset returns incorrect results if a link includes text and an image

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 27 00:57:46 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47365


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #71852|review?                     |review+
               Flag|                            |




--- Comment #7 from Martin Robinson <mrobinson at webkit.org>  2010-10-27 00:57:47 PST ---
(From update of attachment 71852)
View in context: https://bugs.webkit.org/attachment.cgi?id=71852&action=review

Great! Thanks. Perhaps make this small change before landing:

> WebKit/gtk/tests/testatk.c:985
> +    AtkObject* obj = gtk_widget_get_accessible(GTK_WIDGET(webView));
> +    g_assert(obj);
> +
> +    // First paragraph (link at the beginning)
> +    AtkObject* paragraph = atk_object_ref_accessible_child(obj, 0);

Please rename obj to something like "object" to avoid the abbreviation.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list