[Webkit-unassigned] [Bug 48326] [NRWT] Don't use image hash when it's no need in single test mode

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 26 10:34:15 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=48326


Ojan Vafai <ojan at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #71885|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #2 from Ojan Vafai <ojan at chromium.org>  2010-10-26 10:34:14 PST ---
(From update of attachment 71885)
View in context: https://bugs.webkit.org/attachment.cgi?id=71885&action=review

Can you move this into a function call so the logic can be shared with the logic on line 521?

> WebKitTools/Scripts/webkitpy/layout_tests/layout_package/dump_render_tree_thread.py:202
> +        image_hash = test_info.image_hash()
> +        if (image_hash and
> +            (self._test_args.new_baseline or self._test_args.reset_results or
> +            not self._options.pixel_tests)):
> +            image_hash = ""

How about:
if self._test_args.new_baseline or self._test_args.reset_results or not self._options.pixel_tests:
    image_hash = None
else:
    image_hash = test_info.image_hash()

I find that logic moe clear and readable. Also, I prefer using None to the empty string. That's more consistent with python style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list