[Webkit-unassigned] [Bug 25539] spellcheck='' should be the same as spellcheck="true"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 24 20:15:33 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=25539





--- Comment #6 from MORITA Hajime <morrita at google.com>  2010-10-24 20:15:33 PST ---
Hi Tony,
Thank you for taking a look!
I updated the patch.

(In reply to comment #4)
> (From update of attachment 71543 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=71543&action=review
> 
> > WebCore/dom/Element.h:327
> > +    SpellcheckAttributeState spellcheckAttributeState() const;
> 
> Can this method be private?
Fixed.

> 
> > WebCore/dom/Element.h:328
> > +    bool spellCheckingEnabled() const;
> 
> I would name this isSpellCheckingEnabled to match similar methods.
Renamed. I also renamed Editor::spellCheckingEnabledInFocusedNode as well.

> 
> > WebCore/editing/Editor.cpp:2551
> > +    const Element* focusedElement = node->isElementNode() ? toElement(node) : node->parentElement();
> 
> Is it possible that node->parentElement() is null, but node->parent()->parentElement() is true?
I'm sorry but I could not get the point.
My intention here is to ensure that we check against Element class because node might be Text.
And Text might be orphaned.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list