[Webkit-unassigned] [Bug 25539] spellcheck='' should be the same as spellcheck="true"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 22 10:17:25 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=25539


Tony Chang <tony at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #71543|review?                     |review-
               Flag|                            |




--- Comment #4 from Tony Chang <tony at chromium.org>  2010-10-22 10:17:25 PST ---
(From update of attachment 71543)
View in context: https://bugs.webkit.org/attachment.cgi?id=71543&action=review

> WebCore/dom/Element.h:327
> +    SpellcheckAttributeState spellcheckAttributeState() const;

Can this method be private?

> WebCore/dom/Element.h:328
> +    bool spellCheckingEnabled() const;

I would name this isSpellCheckingEnabled to match similar methods.

> WebCore/editing/Editor.cpp:2551
> +    const Element* focusedElement = node->isElementNode() ? toElement(node) : node->parentElement();

Is it possible that node->parentElement() is null, but node->parent()->parentElement() is true?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list