[Webkit-unassigned] [Bug 47542] Web Inspector: need a breakpoint for the timer events.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 13 05:47:03 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=47542


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #70600|review?                     |review-
               Flag|                            |




--- Comment #2 from Pavel Feldman <pfeldman at chromium.org>  2010-10-13 05:47:02 PST ---
(From update of attachment 70600)
View in context: https://bugs.webkit.org/attachment.cgi?id=70600&action=review

> WebCore/inspector/InspectorInstrumentation.cpp:46
> +static const char* const timeoutEventName = "extended.timeout";

"timeout" is a bad name for the event. timerFire (localized "Timer fire" in UI) sounds more user-friendly.
Also, encoding extended event names using dot-separated strings is fragile: there is no guarantee event will not have similar name. So you should either create a pair here or be more creative about encoding the event names.

> WebCore/inspector/front-end/BreakpointManager.js:508
> +        if (this._eventName.search(prefix) !== 0)

Nit: use indexOf instead of regex search.

> WebCore/inspector/front-end/BreakpointsSidebarPane.js:251
> +            "HTML frame/object": ["load", "error", "resize", "scroll", "extended.timeout"]

I think you are adding confusion here: timeout is not a real event. I think we should we have a separate category for it. It might have all timer-related breaks such as setTimeout, clearTimeout and timerFire event.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list